Hose Bib - Slow to Flow

Discussion in 'Plumbing Forum, Professional & DIY Advice, Tips & ' started by keithplumb, Oct 27, 2009.

  1. keithplumb

    keithplumb New Member

    Messages:
    10
    Location:
    Kent, WA
    I moved into a house built in 1997 and one of the annoying things was a hose bib off my garage that would sometimes turn on when the water turned on, and sometimes you would have to wait a few seconds to a few minutes for the water to flow.

    This and a little drip annoyed my, so I ripped out the old one and of course decided to upgrade the ball valve back in the garage to a quarter turn and redid everything. All new hardware so I figured this issue along with a few drips would be fixed. Well the drips were fixed but not the "slow to flow" issue. Anyone have any ideas what is causing this? I searched the forum to no avail.
  2. Lakee911

    Lakee911 I&C Engineer (mostly WWTP)

    Messages:
    1,328
    Location:
    Columbus, OH
    Are you on a well? If so, any chance air is getting in the line and ending up there?
  3. keithplumb

    keithplumb New Member

    Messages:
    10
    Location:
    Kent, WA
    Just on a municipal water supply. Never had it happen anywhere else in the house or outside the house, just this one spot.
Similar Threads: Hose Slow
Forum Title Date
Plumbing Forum, Professional & DIY Advice, Tips & Extending Dishwasher Drain Hose Wednesday at 10:39 AM
Plumbing Forum, Professional & DIY Advice, Tips & Outdoor Spicket-to-hose Aug 27, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Pull-out hose kitchen sink leak Aug 15, 2014
Plumbing Forum, Professional & DIY Advice, Tips & Mystery Pipes and adding a hose bib Jun 25, 2014
Plumbing Forum, Professional & DIY Advice, Tips & below-sink hose connector? Jun 2, 2014

Share This Page