GE GXSF40H Brine tank overflowing

Discussion in 'Water Softener Forum, problems, installation and r' started by KStatefan, Dec 11, 2012.

  1. KStatefan

    KStatefan New Member

    Joined:
    Jan 23, 2012
    Location:
    Manhattan, Kansas
    I have a GE water softner that is not pulling brine from the tank. I have cleaned the nozzle and venturi assembly. Any suggestions on what to look for next?
     
  2. Tom Sawyer

    Tom Sawyer In the Trades

    Joined:
    Nov 29, 2010
    Location:
    Maine
    Loose fittings on the brine line
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. mialynette2003

    mialynette2003 Member

    Joined:
    Nov 24, 2010
    Occupation:
    Owner of SWS Systems WWW.SWSSYSTEM.COM
    Location:
    Ocala, Florida
    Put the unit into a brine draw cycle. Disconnect the brine line from the valve. If water is coming out, than you need a rotor seal kit and possible a rotor.
     
  5. KStatefan

    KStatefan New Member

    Joined:
    Jan 23, 2012
    Location:
    Manhattan, Kansas
    Thanks That seems to be the issue.
     
Similar Threads: GXSF40H Brine
Forum Title Date
Water Softener Forum, problems, installation and r Hard water and not enough water installed in brine tank after regen Feb 2, 2016
Water Softener Forum, problems, installation and r Brine suction line to two control heads Jan 28, 2016
Water Softener Forum, problems, installation and r Weak Brine Flow Draw Clack WSI Jan 8, 2016
Water Softener Forum, problems, installation and r Do I need a new brine valve on Fleck 5600? Oct 30, 2015
Water Softener Forum, problems, installation and r Rainsoft Q2 not drawing brine during cycle -- any suggestions? Oct 8, 2015

Share This Page