flushmaster toilet fills/runs longer than normal

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by gcook, Jul 2, 2007.

  1. gcook

    gcook New Member

    Jul 2, 2007
    I have a 1 button flushmaster toilet. There is a black plastic container inside the back of the toilet, so there is no water that fills, except inside the black container.

    When I flush the toilet it is not filling up immediately. It is running. It is is similir to a standard toilet when you flush it and the stopper comes up and doesn't close correctly so the tank never fills. I am not sure how to troubleshoot this one. I took the top of the back after I flushed it and toggled the lever that goes into the black tank, up and down a few times and it seems to fill. Do you know how I can fix this? The toilet eventually fills and stops running, but you have to tinker with the flush button until it does "something", and starts to fills.
  2. jimbo

    jimbo Plumber

    Aug 31, 2004
    San Diego
    It sounds like you have a Sloan Flushmate in your tank, it that correct? The cartridge right in the middle can be replaced and will solve your problem. Confirm the Sloan model number on the black tank, and any plumbing supplier should have the part. It comes with installation instructions, and is not difficult/
  3. Sponsor

    Sponsor Paid Advertisement

Similar Threads: flushmaster toilet
Forum Title Date
Plumbing Forum, Professional & DIY Advice Moving Toilet, Adding Shower To Toilet Drain Line - Please Check Diagram Saturday at 7:40 PM
Plumbing Forum, Professional & DIY Advice sink drain into toilet drain Nov 22, 2015
Plumbing Forum, Professional & DIY Advice Newbie Wet Vent Question: Tub->Toilet->Sink Nov 22, 2015
Plumbing Forum, Professional & DIY Advice Very slow flush on new Toto Aquia toilet installed in lower level Nov 16, 2015
Plumbing Forum, Professional & DIY Advice Toilet still leaking after replacing flapper, possibly worse than before Nov 11, 2015

Share This Page