Fleck 9100 Useage Mete Problem

Discussion in 'Water Softener Forum, problems, installation and r' started by Gerrylc, Dec 22, 2010.

  1. Gerrylc

    Gerrylc New Member

    Messages:
    3
    Location:
    Maryland
    I am trying to find out how to trouble shout the electronic meter on my Fleck 9100 system. It does not count the usage, the display stays at the same count as if it just regenerated.
  2. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,483
    Location:
    Alaska
    If you have a small magnet you could remove the end piece that is in the meter housing and pass the magnet over the end and see if the water spout flashes.

    Is this a new challenge or one that has been going on for some time?
  3. Gerrylc

    Gerrylc New Member

    Messages:
    3
    Location:
    Maryland
    The meter housing is dome shaped. It has the wires going into the housing on one side of it with a small screw to hold them in. I bought the system used and it has not worked since it was installed about a week ago. I have checked toe voltage on the pc board and it reads 15.4 vdc from the center terminal to both outside terminals and does not change when the water is flowing.
  4. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,483
    Location:
    Alaska
    So you have the dome elect meter..
    Have you passed a magnet over the end of the cable to see if there is any reading?
    When you have water running is it possible to hear if the wheel in that meter assembly is turning?
    It could be that the meter cable assembly needs to be replaced.. they can go bad, not often but they can go bad.
  5. Gary Slusser

    Gary Slusser That's all folks!

    Disconnect the meter cable from the circuit board and clean the contacts and see what happens. If no help, then take the meter turbine out (of the outlet) on the control valve and make sure it spins freely by blowing on it. Blow toward it from the control valve (it measures as water flows out of the control) watching the display and see if you see and pulsing icon etc.. If so then put it back, if not then the meter, cable or circuit board is bad.
  6. Gerrylc

    Gerrylc New Member

    Messages:
    3
    Location:
    Maryland
    I found the problem

    The problem was resin in the gear which caused the wheel not to turn.
    Thanks for those who responeded to my problem
  7. Gary Slusser

    Gary Slusser That's all folks!

    Thanks for letting us know what you found.

    You have another problem and the meter not working was only a symptom, a hint if you will.

    The volume of resin in the outlet to be able to stop the turbine wheel from spinning is indication of a serious problem like a bad o-ring around the distributor tube (up in the control valve or the tank adapter for the second tank, or a cracked distributor tube or bottom basket on the bottom of the distributor tube in either tank.

    Those are the only ways that resin gets out of the tanks into your plumbing. And if the DT or bottom baskets breaks more, resin can plug up appliances and valves etc. and drive you nuts for months until you get all the resin out of the lines etc.. Which can be quite expensive.
Similar Threads: Fleck 9100
Forum Title Date
Water Softener Forum, problems, installation and r Fleck 9100 problem Sep 10, 2013
Water Softener Forum, problems, installation and r Fleck 9100 Timer ID Jan 13, 2011
Water Softener Forum, problems, installation and r Had Fleck 9100 installed last January and my water is still brown Jul 22, 2010
Water Softener Forum, problems, installation and r Fleck 9100 and well gpm questions Jun 30, 2010
Water Softener Forum, problems, installation and r Fleck 9100 Metered Twin Tank Water Softener - 24,000 Grain Dec 11, 2009

Share This Page