Fleck 2510sxt - Problem with losing my settings over time

Discussion in 'Water Softener Forum, problems, installation and r' started by chargedmr2, Jan 11, 2011.

  1. chargedmr2

    chargedmr2 New Member

    Messages:
    15
    Location:
    TX
    Hello everyone,

    Several weeks back I became suspicious that hard water had entered our system and I went back to check the settings--several of my settings had changed back to default. For example the reserve capacity (which was at 200g) was set back to 0. I also noticed that the timings for the backwash, rapid rinse, etc. were back to default settings. Over the course of the last several months we have had a power outage or two (but only for a minute or two). Could this be the cause?

    I thought I was going crazy, but we just had another power outage (again, only for minutes) and today I went to set the clock on the unit and decided to double check the settings. Everything was as I set it, except the reserve capacity was back to 0. This is really becoming a hassle. Any ideas as to what is going on???
  2. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,493
    Location:
    Alaska
    Depending on the age of the unit , the control board could still be under warrenty. I would check with who you bought the unit from and check.
  3. chargedmr2

    chargedmr2 New Member

    Messages:
    15
    Location:
    TX
    The unit was installed last August, so it's still pretty new. Based on this situation, does it sound like a bad unit?? Could it be anything else?
  4. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,493
    Location:
    Alaska
    The part that is changing is part of a write only , or that you have to change it by entering the programing and changing the numbers if it is changing the a setting then there is a chip that is not right.
  5. Gary Slusser

    Gary Slusser That's all folks!

    The SXT has a capacitor backup for retaining the settings, unlike a battery. So if you are losing power and a setting, the circuit board would be the place to look.Unless you are pushing a button and not locking the settings somehow.

    You could test it by doing the settings and then unplugging it and checking the settings again. Whoever you bought it from probably would need that type info anyway. Well that depends on how, or if they will honor the warranty.They should replace the circuit board rather than the control valve.
  6. JKERN

    JKERN New Member

    Messages:
    49
    Location:
    Artesia NM
    I live in an area of new mexico thats prevelant to power outages and have been a Pentair dealer for man years and this is like Gary said a board problem but just in case you dont have one you should also put a surge protector on your electronic controls its never a waste if you wont have problems again.
  7. chargedmr2

    chargedmr2 New Member

    Messages:
    15
    Location:
    TX
    I've finally got around to looking into this problem more and I now believe it was an issue caused by user error. As it turns out, when you enter the master settings menu it is done by holding the up and down arrows at the same time (with time set to 12:01). The first setting that is displayed when entering is the Gallons or Liters option. After messing around a bit, I discovered that when I toggle this very fist setting (from Gallons to Liters and back to Gallons) it resets the reserve capacity to 0 and sets the system capacity to 24,000 grains. I replicated this several times. Interestingly enough, when entering the master settings, it is not uncommon (for me) to accidentally toggle this first setting--I like to think the down arrow will bring me to the next setting option, but of course this is the function of the extra cycle button.

    I should mention that this is what I discovered after killing the power several times and realizing that the settings of concern, did not, in fact reset.

    Can anyone confirm that toggling this first setting should reset the system and reserve capacity settings?

    In the end, I think all is well now that I realize what I did.
    Last edited: Apr 3, 2011
  8. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,493
    Location:
    Alaska
    I would have to check about the resetting to factory, but there was some thing about that in one of my talks with Fleck and my supplier...

    The reserve capacity is either in gallons or in % of capacity.....
  9. SemiHandyRon

    SemiHandyRon New Member

    Messages:
    46
    Location:
    Fairfield, OH
    I have a new 2510SXT myself. Only "settings complaint" thus far is that it doesn't keep clock-time very well. Seems to gain about a minute every two days.
Similar Threads: Fleck 2510sxt
Forum Title Date
Water Softener Forum, problems, installation and r Settings for our new Fleck 2510sxt 48,000 gr. softener w/ 1.5 cu' SST 60 resin Apr 3, 2011
Water Softener Forum, problems, installation and r Fleck 2510sxt settings for efficient potassium chloride use? Jul 31, 2010
Water Softener Forum, problems, installation and r Fleck 5600 vs 7000 Oct 27, 2014
Water Softener Forum, problems, installation and r New install Fleck 5600 Oct 2, 2014
Water Softener Forum, problems, installation and r Need help programming new Fleck SXT timer Jul 24, 2014

Share This Page