Ecowater softner

Discussion in 'Water Softener Forum, problems, installation and r' started by woodsmith6, Mar 3, 2013.

  1. woodsmith6

    woodsmith6 New Member

    Messages:
    3
    Location:
    centereach new york
    Hey Guys!
    I've had or rather got ripped off around 18 years ago when I purchased a Ecowater softener. Disassembled unit recently because i knew that my resin was shot (water flow at faucets was greatly reduced. water flow returned when unit was in bypass.) Examined media and found it to be like fine silt. Purchased new resin ( not Eco water resin! ecowater company must be government protected. Impossible to purchase parts ). Refilled resin tank 3/4 full, reassembled unit. Flushed system, ran water for a week now. NO SOFT WATER! What gives? Installed new spider gaskets lubed with silicone grease. It's almost as though water isn't passing through resin?! I set it to regenerate, brine seems to be functioning properly.
  2. Akpsdvan

    Akpsdvan In the Trades

    Messages:
    1,482
    Location:
    Alaska
    After you refilled the media tank with the new resin and put the upper basket back into place, there should have been an O ring on top of the distributor , is it possible that the o ring is missing? broke?
    That is where I would be looking.
  3. woodsmith6

    woodsmith6 New Member

    Messages:
    3
    Location:
    centereach new york
    thank you! I will check that!
  4. woodsmith6

    woodsmith6 New Member

    Messages:
    3
    Location:
    centereach new york
    Thank you the "O" ring worked!
Similar Threads: Ecowater softner
Forum Title Date
Water Softener Forum, problems, installation and r EcoWater ESD 2502R39 Not Regenerating May 17, 2014
Water Softener Forum, problems, installation and r water accumulating in salt tank Ecowater 3500 May 11, 2014
Water Softener Forum, problems, installation and r water softener continuously runs to drain ECR 3500 Ecowater Feb 7, 2013
Water Softener Forum, problems, installation and r EcoWater System Parts - Help Oct 26, 2010
Water Softener Forum, problems, installation and r Ecowater 3000 series No water enters brine tank Jul 30, 2010

Share This Page