Ducane furnace still not lighting. No power where ignitor connects to smart valve.

Discussion in 'HVAC Heating & Cooling' started by Dean M, Oct 4, 2010.

  1. Dean M

    Dean M New Member

    Jun 25, 2006
    On Sept 28th I posted the following: Ducane Furnace model # MPGA07583A. When I turn on the thermostat the exhaust fan turns on for about 25 seconds then the unit shuts down. The error code blinks 3 times then hesitates then blinks again 3 times. The ignitor does not glow and the main fan does not turn on. Right before this problem the igniter would glow, the burners would ignite and the main fan would run for about 25 seconds and then the unit would shut down. The green light on the control then blinks an error code 3 times.

    I replaced the ignitor per suggestion and still no working furnace. I tested the smart valve where the ignitor connects and I am getting no voltage once the thermostat is set and the furnace starts its cycle.

    Question: Could it be a bad smart valve or a bad control board? Why am I not getting any power from the smart valve where the ignitor connects too?

    Also, can anyone suggest a good internet source for parts? Thanks.

Similar Threads: Ducane furnace
Forum Title Date
HVAC Heating & Cooling Ducane furnace model MPGA problem Apr 12, 2013
HVAC Heating & Cooling Ducane furnace not lighting. Draft inducer or pressure switch? Oct 4, 2010
HVAC Heating & Cooling Ducane furnace will not light then shuts down Sep 27, 2010
HVAC Heating & Cooling ducane MPGA100B4B not lighting Mar 16, 2015
HVAC Heating & Cooling Ducane burner, perhaps pilot, won't light Jan 3, 2014

Share This Page