Disconnecting a Glacier Bay Quick Connect and/or water flow issues.

Discussion in 'Plumbing Forum, Professional & DIY Advice' started by Adam Conklin, Apr 28, 2013.

  1. Adam Conklin

    Adam Conklin New Member

    Messages:
    2
    Location:
    Pennsylvania
    I have a Glacier Bay faucet that was working fine until about 4:30 this afternoon have had it for a few months. My problem is water pressure/flow. I've done a usual suspects and have narrowed the problem down to the hose connecting the pull spout head/sprayer. I've tried pushing wire down to clear a blockage but seem to be stuck at the end of it. Does anybody have any suggestions on how I can get water flow back?
  2. Adam Conklin

    Adam Conklin New Member

    Messages:
    2
    Location:
    Pennsylvania
  3. Terry

    Terry Administrator Staff Member

    Messages:
    15,298
    Location:
    Bothell, Washington
    It would normally be at the aerator.
Similar Threads: Disconnecting Glacier
Forum Title Date
Plumbing Forum, Professional & DIY Advice Disconnecting pipe from stub Jan 10, 2010
Plumbing Forum, Professional & DIY Advice Glacier Bay Leonardo faucet, Trouble Removing Handles Mar 20, 2014
Plumbing Forum, Professional & DIY Advice Strange problem with Glacier Bay Kitchen faucet Apr 3, 2013
Plumbing Forum, Professional & DIY Advice Trouble finding Glacier Bay faucet handle adapters. Oct 13, 2012
Plumbing Forum, Professional & DIY Advice Glacier Bay vanity top basin drain Dec 27, 2010

Share This Page