Culligan MK 50 programming settings

Discussion in 'Water Softener Forum, problems, installation and r' started by Outhouse, Aug 8, 2010.

  1. Outhouse

    Outhouse New Member

    Messages:
    5
    Location:
    Chesapeake, VA
    I've had a Culligan MK 50 for 6 years and after the original company installation, the settings just don't seem proper. There are 3 adults in the home and occasionally the toilet water is brown and the water has an iron smell. There's no bridging in the salt tank, but have noticed it uses less salt when I switched to a higher quality salt with "red out" (is this dreaming, or could it be?)
    I just today changed the settings to:SLEP 15, BUU 25, BR 60, CAP 31 and am currently regenerating. The new settings are higher than previously set.
    Am I in the Outhouse with these settings?
    I would appreciate suggested settings for this unit based on the above information. Thanks!
  2. Bob999

    Bob999 In the Trades

    Messages:
    448
    Location:
    Pennsylvania
    To properly set up your unit you need to provide a water analysis that includes, at a minimum, hardness, iron, manganese, pH, and TDS.

    Your water quality could have changed over 6 years or the unit may not be functioning properly. Changing the salt will not change the amount of salt used--but a malfunctioning unit can use less salt and not provide adequate softening.
  3. Outhouse

    Outhouse New Member

    Messages:
    5
    Location:
    Chesapeake, VA
    Thanks for the reply, I'll get a water sample tested and post results for comments from the experts here.
Similar Threads: Culligan programming
Forum Title Date
Water Softener Forum, problems, installation and r Culligan Installation/programming manual Apr 29, 2014
Water Softener Forum, problems, installation and r culligan programming questions Sep 26, 2013
Water Softener Forum, problems, installation and r Culligan MK 50 programming settings - missing a step? Time for a change? Sep 26, 2010
Water Softener Forum, problems, installation and r Culligan Softener always running Sep 10, 2014
Water Softener Forum, problems, installation and r Help to ID Culligan and program Aug 9, 2014

Share This Page