1. Juan Angelo Isaac Batista

    Juan Angelo Isaac Batista New Member

    Joined:
    Oct 19, 2012
    Location:
    Florida
    I have been using a Clack WS-1 CS version a 1" water softener that for almost 5 years was working fine. All of a sudden I noticed my water getting hard so I thought maybe I had forgotten to add salt so I went to check on it. I opened the tank and it was full of salt and for the past couple of months I have noticed that the salt is not going down even after forced regenerations.

    So I need help in troubleshooting the unit to see what is going on.

    I bought this unit from Gary Slusher in April 2007 and have been quite satisfied with the unit until now.

    After five years of enjoying soft water I can honestly say that hard water sucks!

    Any and all help is greatly appreciated.

    ANgelo
     
  2. mialynette2003

    mialynette2003 Member

    Joined:
    Nov 24, 2010
    Occupation:
    Owner of SWS Systems WWW.SWSSYSTEM.COM
    Location:
    Ocala, Florida
    Is there more water in the salt tank than normal? Can you step the unit through each cycle? If so, put unit into a draw cycle to see if it has suction. If it has no suction, that the venturi may be clogged. Put the unit into a fill cycle and see if it will fill the brine tank. If not, then the brine flow control may be clogged.
     
  3. Sponsor

    Sponsor Paid Advertisement

     
  4. Gary Slusser

    Gary Slusser That's all folks!

    Joined:
    Aug 31, 2004
    Occupation:
    Retired
    Location:
    Wherever I park the motorhome.
    First check that there are no loose brine line compression fittings (you have two in the salt tank [top and bottom of the float valve] and one on the control valve) and that there is no hollow spot under the surface of the salt; that's called a salt bridge and it prevents salt from being dissolved by water and the softener has been regenerating without any salt.

    Regardless of what's wrong, when you get it 'fixed', you follow the instructions I sent you when you bought the softener and do 2 manual regenerations at the salt dose of 15 lbs/cuft of resin you have.
     
    Last edited: Nov 12, 2012
Similar Threads: Clack Softening
Forum Title Date
Water Softener Forum, problems, installation and r Clack WS1 not softening Jun 5, 2014
Water Softener Forum, problems, installation and r Clack WS1 not softening very long Jan 29, 2014
Water Softener Forum, problems, installation and r Clack Valve WS1 reversed water flow in iron filter. Yesterday at 2:02 PM
Water Softener Forum, problems, installation and r Want to buy a clack ws1.25 Aug 22, 2015
Water Softener Forum, problems, installation and r Clack System Quote & Questions May 21, 2015

Share This Page