1 yr old water heater and its already ugly! please look

Discussion in 'Water Heater Forum, Tanks' started by gsinc, Aug 23, 2011.

  1. gsinc

    gsinc New Member

    Aug 23, 2011
    I just installed an electric water heater (brand GSW) a year and 4 months ago. Last week we stopped getting hot water due to the breaker blowing, I called over the electrician to trouble shoot and he said it was the lower element that went, So last night i tried replacing it but was sold the wrong element, as i was getting ready to change it, I shut power off, turned water off, drained tank and then pulled lower cover off and came across a rusty bottom. My question, is this normal, I have attached some pics of the lower and upper element hook ups and of the old element. I am going to store where it was purchased today to see if they have any advice on this, I just wanted some other unbias opionions with what i should do or if this is normal.

    IMG-20110823-00273.jpg IMG-20110823-00274.jpg IMG-20110823-00275.jpg
  2. Jack_Mason

    Jack_Mason HVAC Expert

    Aug 24, 2011
    new york, ny
    Definitely not normal for a new unit. Which brand/model is this?
  3. Sponsor

    Sponsor Paid Advertisement

Similar Threads: water heater
Forum Title Date
Water Heater Forum, Tanks Loud burner? 75 Gallon US Craftmaster water heater (propane) see pic? Yesterday at 5:19 PM
Water Heater Forum, Tanks Hot water heater - infrequent use - selecting a new one Oct 18, 2016
Water Heater Forum, Tanks Water Heater Strapping Conundrum Oct 17, 2016
Water Heater Forum, Tanks Brown sticky spots on and around water heater?? Sep 26, 2016
Water Heater Forum, Tanks Lukewarm water from series heaters Sep 25, 2016

Share This Page